Руководство пользователя

Авторское право на данный документ © 2010-2015 принадлежит его разработчикам (соавторам), перечисленным ниже. Вы можете распространять и/или изменять егов соответствии с правилами лицензии GNU General Public License (http://www.gnu.org/licenses/gpl.html), версии 3 или более поздней, или лицензии типа Creative Commons Attribution License(http://creativecommons.org/licenses/by/3.0/), версии 3.0 или более поздней.

Все торговые знаки этого руководства принадлежат его владельцам.

Соавторы

The KiCad Team

Перевод

KiCad Russian Team + alex9 <gmdii@mail.ru>

Обратная связь

Просьба оставлять все комментарии и замечания на следующих ресурсах:

Дата публикации

16 апреля 2016 года.

1. Знакомство c GerbView

GerbView предназначен для просмотра файлов в формате Gerber (RS 274 X) и отображения файлов сверловки из Pcbnew (в формате Excellon).

Можно открыть до 32 файлов (Gerber и/или файлы сверловки).

Файлы могут быть отображены в прозрачном или пакетном режиме.

Для получения дополнительной информации о формате файлов Gerber воспользуйтесь спецификацией The Gerber File Format Specification - Ucamco.

2. Основное окно

gerbview_main_screen_png

3. Верхняя панель инструментов

gerbview_top_toolbar_png

gerbview_clear_layers_png

Очистить все слои

gerber_file_png

Загрузить файлы Gerber

gerbview_drill_file_png

Загрузить файлы сверловки (формат Excellon из Pcbnew)

sheetset_png

Выбрать рамку листа для печати и показать/скрыть границы страницы

print_button_png

Открыть диалог печати

zoom_in_png zoom_out_png

Увеличение и уменьшение масштаба

zoom_redraw_png

Перерисовать

zoom_fit_in_page_png

Автомасштаб

gerbview_top_layer_png

Выбор слоя

gerbview_top_dcode_png

Выбор D-кода (подсветка элементов, которые используют этот D-код на выбранном слое)

gerbview_top_info_png

Информация о свойствах файла Gerber, загруженного в выбранный слой

4. Левая панель инструментов

gerbview_left_toolbar_png

grid_png

Показать / скрыть сетку

polar_coord_png

Использовать полярные координаты

unit_inch_png unit_mm_png

Выбор единицы измерения

cursor_shape_png

Изменить форму курсора

pad_sketch_png

Отображать контактные площадки в контурном режиме

track_sketch_png

Отображать линии в контурном режиме

opt_show_polygon_png

Отображать полигоны в контурном режиме

gerbview_show_negative_objects_png

Отображать негативные объекты в дополнительном цвете

show_dcodenumber_png

Отображать значения D-кодов

gbr_select_mode0_png gbr_select_mode1_png gbr_select_mode2_png

Режимы отображения слоёв

5. Команды меню

5.1. Меню "Файл"

gerbview_file_menu_png

Позволяет загрузить файлы Gerber и файлы сверловки Gerbview. Существует также вспомогательная возможность экспорта файлов Gerber в Pcbnew.

5.1.1. Экспорт в Pcbnew

GerbView имеет ограниченные возможности для экспорта Gerber-файлов в Pcbnew.

Конечный результат зависит от того, какие особенности формата RS 274 X используются в Gerber-файлах.

RS 274 X имеет растрово-ориентированные функции (в основном, относящиеся к негативным объектам), которые не могут быть преобразованы.

Элементы, заданные командой Gerber "засветка", преобразуются в переходные отверстия.

Элементы, заданные командой Gerber "линия", преобразуются в отрезки (или в графические линии для не медных слоев).

Таким образом, удобство и простота использования преобразованного файла сильнозависит от того, как каждый файл Gerber был построен оригинальным Pcb-инструментом.

5.2. Меню "Настройки"

gerbview_preferences_menu_png

Предоставляет доступ к редактору горячих клавиш и некоторых параметров отображения.

5.3. Меню "Разное"

gerbview_misc_menu_png
  • "Список D-кодов" показывает используемые D-коды и некоторые их параметры.

  • "Показать содержимое файла" отображает содержимое Gerber-файла активного слоя в текстовом редакторе.

  • "Очистить слой" стирает содержимое активного слоя.

6. Менеджер слоёв

Менеджер слоёв позволяет:

  • Выбрать активный слой

  • Показать / скрыть слой

gerbview_layer_manager_png

Активный слой рисуется после остальных слоев.

При загрузке нового файла используется активный слой (новые данные заменяют предыдущие данные).

Примечания:

  • Щелчок левой кнопкой мыши на строке - выбор активного слоя.

  • Щелчок правой кнопкой мыши на менеджере слоёв - управление отображением сразу всех слоёв.

  • Щелчок средней кнопкой мыши на индикаторе цвета - выбор цвета слоя.

6.1. Режимы отображения слоёв.

  • Режим "без обработки" gbr_select_mode0_png

Каждый Gerber-файл и каждый элемент в файлах рисуются в порядке загрузки файлов.

Однако активный слой рисуется последним.

Если Gerber-файлы имеют негативные элементы, то на уже нарисованных слоях появляются артефакты.

gerbview_mode_raw_stack_png
  • "Пакетный" режим gbr_select_mode1_png

Каждый Gerber-файл рисуется в порядке загрузки.

Активный слой рисуется последним.

Если Gerber-файлы имеют негативные элементы, то на уже нарисованных слоях артефакты не появляются,потому что каждый файл рисуется в локальном буфере перед отображением на экране.

gerbview_mode_raw_stack_png
  • "Прозрачный" режим gbr_select_mode2_png

gerbview_mode_transparency_png

6.2. Воздействие выбора слоя на отрисовку

Это воздействие видно только в режиме "без обработки" и в "пакетном" режиме.

Слой 1 (зелёный) нарисован после Слоя 2

gerbview_layer_select_1_png

Слой 2 (синий) нарисован после Слоя 1

gerbview_layer_select_2_png

7. Печать слоёв

7.1. Доступ к диалогу печати

Для печати слоёв используйте кнопку print_button_png или меню "Файл".

Предостережение

Убедитесь, что элементы находятся внутри области печати (выберите с помощью sheetset_png подходящий формат страницы).

Не забывайте, что фотоплоттеры могут использовать зону печати намного большую, чем размер страниц, используемых принтерами).

Довольно часто требуется перемещение всех слоёв целиком (см. "Процедура перемещения блока").

7.2. Процедура перемещения блока

Можно переместить элементы Gerber сразу во всех слоях:

  • удерживая нажатой левую кнопку мыши выделите область, содержащую нужные элементы;

  • переместите выбранную область;

  • для завершения операции щёлкните левой кнопкой мыши.