Руководство пользователя

This document is Copyright © 2010-2018 by it’s contributors as listed below. You may distribute it and/or modify it under the terms of either the GNU General Public License (https://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (https://creativecommons.org/licenses/by/3.0/), version 3.0 or later.

Все торговые знаки этого руководства принадлежат его владельцам.

Соавторы

The KiCad Team

Перевод

KiCad Russian Team + alex9 <gmdii@mail.ru>

Обратная связь

Просьба оставлять все комментарии и замечания на следующих ресурсах:

Дата публикации

Published on February 24, 2018.

1. Знакомство c GerbView

GerbView предназначен для просмотра файлов в формате Gerber (RS 274 X) и отображения файлов сверловки из Pcbnew (в формате Excellon). Одновременно может быть показано до 32 файлов.

Для получения дополнительной информации о формате файлов Gerber воспользуйтесь спецификацией the Gerber File Format Specification. Информацию о формате файла сверловки можно получить здесь the Excellon format description.

2. Графический интерфейс

2.1. Основное окно

gerbview_main_screen_png

2.2. Верхняя панель инструментов

gerbview_top_toolbar_png

delete_gerber_png

Clear all layers

load_gerber_png

Load Gerber files

gerbview_drill_file_png

Загрузить файлы сверловки (формат Excellon из Pcbnew)

sheetset_png

Выбрать рамку листа для печати и показать/скрыть границы страницы

print_button_png

Открыть диалог печати

zoom_redraw_png

Перерисовать

zoom_in_png zoom_out_png

Увеличение и уменьшение масштаба

zoom_fit_in_page_png

Автомасштаб

zoom_area_png

Zoom to selection

gerbview_top_layer_png

Select active layer

gerbview_top_info_png

Display info about active layer

gerbview_x2_component_png

Highlight items belonging to selected component (Gerber X2)

gerbview_x2_net_png

Highlight items belonging to selected net (Gerber X2)

gerbview_x2_attributeo_png

Highlight items with the selected attribute (Gerber X2)

gerbview_top_dcode_png

Highlight items of selected D Code on the active layer

2.3. Левая панель инструментов

gerbview_left_toolbar_png

cursor_png

Select items

measurement_png

Measure between two points

grid_png

Toggle grid visibility

polar_coord_png

Использовать полярные координаты

unit_inch_png unit_mm_png

Выбор единицы измерения

cursor_shape_png

Изменить форму курсора

pad_sketch_png

Отображать контактные площадки в контурном режиме

track_sketch_png

Отображать линии в контурном режиме

opt_show_polygon_png

Отображать полигоны в контурном режиме

gerbview_show_negative_objects_png

Отображать негативные объекты в дополнительном цвете

show_dcodenumber_png

Отображать значения D-кодов

gbr_select_mode2_png

Display layers in diff(compare) mode

contrast_mode_png

Display current layer in high-contrast mode

layers_manager_png

Show/hide layer manager

2.4. Менеджер слоёв

gerbview_layer_manager_png

Менеджер слоёв позволяет управлять и контролировать видимость всех слоёв. Стрелка указывает на активный слой, а с помощью отметок можно скрыть или показать нужные слои.

Функции кнопок мыши:

  • Щелчок левой кнопкой мыши на строке: выбор активного слоя.

  • Щелчок правой кнопки мыши на менеджере слоёв: управление отображением сразу всех слоёв.

  • Middle click or double click (on color swatch): select the layer color

The Layers tab allows you to control the visibility and color of all loaded Gerber and drill layers. The Items tab allows you to control the color and display of the grid, D Codes, and negative objects.

3. Команды меню

3.1. Меню "Файл"

gerbview_file_menu_png

Экспорт в Pcbnew имеет ограниченные возможности для экспорта Gerber-файлов в Pcbnew. Конечный результат зависит от того, какие особенности формата RS 274 X используются в Gerber-файлах: растровые элементы (в основном, негативные объекты), не могут быть преобразованы; элементы, заданные командой Gerber "засветка", преобразуются в переходные отверстия; элементы, заданные командой Gerber "линия", преобразуются в отрезки (или в графические линии для не медных слоев)

3.2. Меню "Настройки"

gerbview_preferences_menu_png

3.2.1. Toolsets

GerbView now supports the modern graphics toolset that is available in PcbNew. Enabling the modern toolset brings new features and better performance. You can select which toolset to use in the preferences menu. Using the Modern (Accelerated) toolset is recommended if your graphics card supports it (requires OpenGL 2.0). If your graphics card does not support the Accelerated toolset, you can still use the new features by selecting the Modern (Fallback) toolset.

Using the Legacy toolset is only recommended if you notice that the Modern toolset does not support a feature you need or if it does not render a Gerber file correctly. If you notice such a problem, please notify the KiCad developers so that it can be fixed in a future release.

The Legacy toolset will be removed in a future version of GerbView.

3.3. Меню "Разное"

gerbview_misc_menu_png
  • Список D-кодов показывает используемые D-коды и некоторые их параметры.

  • Показать содержимое файла отображает содержимое Gerber-файла активного слоя в текстовом редакторе.

  • Clear Current Layer erases the contents of the active layer.

  • Set Text Editor… allows you to choose which program to show source with.

4. Режимы отображения слоёв

GerbView имеет три режима отображения, которые будут полезны в различных ситуациях и при разных условиях.

Замечание
"Пакетный" и "прозрачный" режимы обеспечивают наилучшее качество отображения, но на некоторых компьютерах, могут работать медленнее чем режим "без обработки".

4.1. Режим "без обработки"

Этот режим устанавливается с помощью кнопки gbr_select_mode0_png . Каждый файл и каждый элемент из этого файла будет выводится на экран в том порядке, в котором они были загружены. Но при этом, активный слой будет выведен последним.

Если Gerber-файлы имеют негативные элементы, то на уже нарисованных слоях появятся артефакты.

gerbview_mode_raw_stack_png

4.2. "Пакетный" режим

Устанавливается с помощью gbr_select_mode1_png , каждый файл выводится на экран в том порядке, в котором они были загружены. При этом, активный слой, тоже, будет выведен последним.

Если Gerber-файлы имеют негативные элементы, то на уже нарисованных слоях артефакты не появляются, потому что каждый файл рисуется в локальном буфере перед отображением на экране.

gerbview_mode_raw_stack_png

4.3. "Прозрачный" режим

Используйте кнопку gbr_select_mode2_png для отображения в этом режиме, в котором нет никаких артефактов и слои смешиваются вместе с верхним активным слоем.

gerbview_mode_transparency_png

4.4. Скрытые элементы нижних слоёв

В режиме "без обработки" и "пакетном" режиме активный слой всегда располагается вверху, над остальными слоями, и скрывает элементы под собой.

Здесь слой 1 (зелёный) — активный (заметьте, стрелка указывает на него) и он отображается поверх слоя 2 (синего):

gerbview_layer_select_1_png

Сделав слой 2 (синий) активным, он переместиться наверх:

gerbview_layer_select_2_png

5. Перемещение элементов

When using the legacy toolset, items may be selected by holding down the left mouse button and drawing a rectangle. Releasing the button picks up the items. A click of the left mouse button places the items.

This behavior is deprecated and not available in the modern toolsets.

6. Печать

Для печати слоёв используйте кнопку print_button_png или меню Файл → Печать.

Предостережение

Убедитесь, что элементы находятся внутри области печати. Выберите с помощью sheetset_png подходящий формат страницы.

Не забывайте, что фотоплоттеры могут использовать зону печати намного большую, чем размер страниц, используемых принтерами. Может потребоваться переместить весь набор слоёв.