洗練された電子プリント回路基板の開発を成功に導く KiCad をマスターするための必須で簡潔なガイド

このドキュメントは以下の貢献者により著作権所有 © 2010-2018 されています。あなたは、GNU General Public License ( http://www.gnu.org/licenses/gpl.html ) のバージョン 3 以降、あるいはクリエイティブ コモンズ Attribution ライセンス ( http://creativecommons.org/licenses/by/3.0/ ) のバージョン 3.0 以降のいずれかの条件の下で、配布または変更することができます。

このガイドの中のすべての商標は、正当な所有者に帰属します。

貢献者

David Jahshan, Phil Hutchinson, Fabrizio Tappero, Christina Jarron, Melroy van den Berg.

翻訳

je6bmq <je6bmq AT gmail.com>, 2018. starfort <starfort AT nifty.com>, 2017-2019. kinichiro <kinichiro.inoguchi AT gmail.com>, 2015. silvermoon <silvermoon AT kicad.jp>, 2011-2015. yoneken <yoneken AT kicad.jp>, 2011-2015.

フィードバック

バグ報告や提案はこちらへお知らせください:

発行日

2015年5月16日

KiCad のご紹介

KiCad は、電気回路図と基板アートワークを作成するためのオープンソースのソフトウェア ツールです。その一つの外観の下に、KiCad は、以下の独立したソフトウェア ツール群のすばらしい組み合わせを実現しています:

プログラム名 説明 ファイル拡張子

KiCad

プロジェクト マネージャ

*.pro

Eeschema

回路図とコンポーネントのエディター

*.sch, *.lib, *.net

Pcbnew

基板とフットプリントのエディター

*.kicad_pcb, *.kicad_mod

GerbView

ガーバーとドリル ファイルのビューア

\*.g\*, *.drl, etc.

Bitmap2Component

ビットマップをコンポーネントやフットプリントに変換

*.lib, *.kicad_mod, *.kicad_wks

PCB Calculator

コンポーネント、線幅、電気的に安全な間隔、カラーコード等のための計算機

なし

Pl Editor

図枠エディター

*.kicad_wks

ファイル拡張子リストは完全ではなく、KiCad が扱うファイルの一部しか含んでいません。しかしながら、どのファイルが各々の KiCad アプリケーションで使われるかを基本的に理解するのに役立ちます。

KiCad は、複雑な電子基板の開発やメンテナンスにも使えるほど十分にバージョン アップを重ねてきたと言えます。

KiCad には基板サイズの制限がなく、最大32の導体レイヤー、最大14のテクニカル レイヤーそして最大4の補助レイヤーを簡単に扱うことができます。 KiCad は、フォト プロッター用のガーバー ファイル、ドリル ファイル、コンポーネント ロケーション ファイル等のプリント基板作成に必要なファイルを全て作ることができます。

オープン ソース (GPL ライセンスに基づく) であるため、KiCad は、オープン ソース志向の電子機器作成向けプロジェクトに理想的なツールです。

インターネット上の KiCad ホームページ:

KiCad のダウンロードとインストール

KiCad は GNU/Linux、Apple macOS 、Windows で動作します。以下の URL で最新のインストール手順とダウンロードのリンクが見つかります:

KiCad 安定版は KiCad Stable Release Policy に基づいて定期的にリリースされます。新機能は継続的に開発ブランチに追加されています。もしあなたが新機能の利用を希望し、テストを手伝っていただけるのであれば、あなたのプラットホーム向けに作られた最新の夜間ビルドをダウンロードしてください。夜間ビルドにはファイルの破損や不正なガーバーの生成のようなバグがあるかもしれませんが、KiCad 開発チームは新機能の開発中もできるだけ開発ブランチを使用可能にしておくことを目標にしています。

GNU/Linux の場合

KiCad の安定版はほとんどのディストリビューション パッケージ マネージャーで kicad と kicad-doc として見つけることができます。もしあなたがお使いのディストリビューションが最新の安定版を提供していなければ、安定していないビルド用の指示書に従い、最新の安定版を選択してインストールを行ってください。

Ubuntu で、KiCad の安定版ではない夜間ビルドをインストールする最も簡単な方法は PPAAptitude によるものです。端末で次のようにタイプします:

sudo add-apt-repository ppa:js-reynaud/ppa-kicad
sudo aptitude update && sudo aptitude safe-upgrade
sudo aptitude install kicad kicad-doc-en

Debian で、KiCad のバックポートされたビルドをインストールする最も簡単な方法は次の通りです :

# Set up Debian Backports
echo -e "
# stretch-backports
deb http://ftp.us.debian.org/debian/ stretch-backports main contrib non-free
deb-src http://ftp.us.debian.org/debian/ stretch-backports main contrib non-free
" | sudo tee -a /etc/apt/sources.list > /dev/null

# Run an Update & Install KiCad
sudo apt-get update
sudo apt-get install -t stretch-backports kicad

Fedora で、KiCad の安定版ではない夜間ビルドをインストールする最も簡単な方法は copr によるものです。KiCad を copr でインストールするには copr で次のようにタイプします:

sudo dnf copr enable @kicad/kicad
sudo dnf install kicad

あるいは、ダウンロードしてコンパイル済みバージョンの KiCad をインストールしたり、直接ソースコードをダウンロードしてコンパイルし、KiCad をインストールすることもできます。

Apple macOS の場合

macOS 用安定版の KiCad は、以下の URL で見つけることができます: http://downloads.kicad-pcb.org/osx/stable/

安定していない夜間の開発ビルドは、以下の URL で見つけられます: http://downloads.kicad-pcb.org/osx/

Windows の場合

Windows 用の安定版の KiCad は、以下の URL で見つけることができます: http://downloads.kicad-pcb.org/windows/stable/

Windows 用の夜間の開発ビルドは、以下の URL で見つけられます: http://downloads.kicad-pcb.org/windows/

サポート

何か思いついたり、発言したいことがあったり、質問があったり、ヘルプが必要だったり …​ いずれの場合でも:

KiCad 作業の流れ

他の PCB 設計ツールとの類似性がある一方で、KiCad は、回路図のコンポーネントとフットプリントを別に持つ独自のワークフローを特徴としています。回路図を作成した後の時点でのみ、コンポーネントには実際のフットプリントが割り当てられます。

概要

KiCad での作業の流れは2つの主要なタスクで構成されています: 回路図の作成と基板のレイアウトです。コンポーネント ライブラリとフットプリント ライブラリの両方がこれら2つのタスクのために必要です。KiCad には多くのコンポーネントとフットプリントが含まれており、新しく作るためのツールも持っています。

下図は KiCad での作業の流れを示すフローチャートです。このフローチャートはあなたが取る必要のあるステップを、どんな順序で行うのかを説明しています。適用できる場合には便宜上アイコンを付け加えています。

KiCad Flowchart

コンポーネントの作成についての更なる情報は、「回路図シンボルの作成」 をお読み下さい。また、新しいフットプリントの作成方法についての情報は、「フットプリントの作成」 をご覧下さい。

Quicklib は、素早く KiCad のコンポーネントを作成することのできる Web ベースのインターフェイスを持ったツールです。Quicklib についての更なる情報は、「Quicklib による回路図コンポーネントの作成」 を参照して下さい。

フォワード/バック アノテーション

電気回路図を完全に描き終わったら、次のステップはそれを基板に移すことです。しばしば、追加のコンポーネントを付け足す必要があったり、部品を違うサイズに変更したり、ネット名を変更するといったことが起こります。これは2つの方法で行うことができます: フォワード アノテーションとバック アノテーションです。

フォワード アノテーションとは、回路図の情報を対応する基板レイアウト図に送る機能です。少なくとも最初に一度は回路図から基板図へインポートしなければならないので、これは基本的な機能です。その後、回路図の変更はフォワード アノテーションによって基板図へと順次伝えられます。フォワード アノテーションについての詳細は、「KiCad のフォワード・アノテーション」 の章で議論されています。

バック アノテーションとは、基板レイアウト図の変更を対応する回路図に送り戻す処理です。バック アノテーションを招く類似した2つの要因として、ゲートの入替とピンの入替が挙げられます。このような状況では、ゲートやピンは機能的に同一ですが、部品レイアウトの都合によって使われるピンやゲートが選択されて接続される信号が決定されます。基板図で選択が決定されたら、この変更は回路図へと差し戻されます。

KiCad の使用

ショートカット キー

KiCad は関連はあっても異なる2種類のショートカット キーを持っています: アクセラレーター キーとホットキーです。マウスを使う代わりにキーボードをコマンド変更に使うことで、どちらも KiCad での作業の迅速化に使われます。

アクセラレーター キー

アクセラレーター キーは、メニューやツールバー アイコンをクリックするのと同様の効果を持ちます: コマンドは入力されますが、左マウス ボタンがクリックされるまでは何も起きません。コマンド モードで入力したいが直ちに実行はしたくない時にはアクセラレーター キーを使用します。

アクセラレーター キーは全てのメニュー パネルで右端に表示されます :

Accelerator keys

ホットキー

ホットキーはアクセラレーター キーに左マウス クリックを足したものと同じです。ホットキーを使用すると現在のカーソル位置で直ちにコマンドを開始します。ワークフローを中断することなく直ちにコマンドを変更するにはホットキーを使用します。

KiCad のツールでホットキーを参照するには、ヘルプ → ホットキー リスト と辿るか、Ctrl+F1 を押します :

Hotkeys

設定 → ホットキー オプション メニューから、ホットキー割り当ての編集や、ホットキー設定のインポート、エクスポートが行えます。

このドキュメントでは、ホットキーをこのような括弧で表現しています: [a] もし [a] を見たなら、キーボードの "a" キーを押して下さい。

回路図で線を引く簡単な例を考えてみましょう。

アクセラレーター キーを使う場合、 "ワイヤを配置" コマンドを呼び出すよう "Shift + W" を押します (カーソルの形が変わります)。続いて、配線を開始するためには、線を引き始めたい場所でマウスを左クリックします。

ホットキーでは、単に [w] を押すと現在のカーソル位置から直ちに配線が始まります。

電気回路図の作図

この章では KiCad を使って電気回路図を作図する方法を学びます。

Eeschema の使用

  1. Windows の場合は kicad.exe を実行して下さい。Linux の場合は、端末で 'kicad' とタイプして下さい。KiCad プロジェクト マネージャーのメイン ウィンドウが表示されることでしょう。ここから8つの独立したソフトウェア ツールを呼び出すことができます: Eeschema, 回路図ライブラリー エディター, Pcbnew, PCB フットプリント エディター, GerbView, Bitmap2Component, PCB Calulator そして Pl Editor です。主要なツールがどのように使われるのかを理解するには KiCad 作業の流れ の図を参照して下さい。

    KiCad Main Window
  2. 新規プロジェクトを作成します : ファイル新規プロジェクト と辿って下さい。 プロジェクト ファイル名は 'tutorial1' とします。プロジェクト ファイルには拡張子 ".pro" が自動的に付加されるでしょう。ダイアログの外観は使用されているプラットフォームによって異なりますが、必ず新しいディレクトリを作るためのチェックボックスがあります。既にディレクトリを用意しているのでなければ、チェック状態のままにしておきます。全てのプロジェクト ファイルはそこに保存されることになるでしょう。

  3. では回路図の作成を始めましょう。回路図エディター Eeschema を起動します Eeschema 。左から1番目のボタンです。

  4. 次に上部ツールバーにある 'ページ設定' アイコン Sheet settings icon をクリックして下さい。適切な '用紙 サイズ' ('A4','8.5x11' etc.) をセットし、タイトルとして 'Tutorial1' を入力します。. 表示されている他の情報は必要に応じて入力できます。 OK をクリックします。この情報は回路図の下右隅に配置されます。ズームインするにはマウス ホイールを使用してください。 回路図全体を保存します: ファイル保存 と辿って下さい。

  5. 最初の部品を置いてみましょう。右ツールバーにある 'シンボルを配置' アイコン Add component Icon をクリックして下さい。'シンボルを追加' ホットキー [a] を押して配置することもできます。

  6. 回路図シートの中央でクリックして下さい。 シンボルを選択 ウィンドウが画面上に表示されます。 抵抗器を配置してみます。検索欄に Resistor の 'R' と入力し、'R' でフィルター検索をします。 Resistor の上にある見出し 'Device' にお気付きかも知れません。この見出し 'Device' はそのコンポーネントが含まれる、使いやすいように同種のものを集めたライブラリーの名前です。

    Choose Symbol
  7. この上でダブル クリックしてみて下さい。これで 'シンボルを選択' ウィンドウが閉じられます。 配置したい場所でクリックすると、回路図シート内にコンポーネントが配置されます。

  8. ズームインするにはコンポーネント上で拡大鏡をクリックします。あるいは、マウス ホイールを使ってズームイン、ズームアウトができます。水平方向と垂直方向にパンするにはマウスのホイール (中央) ボタンを押します。

  9. コンポーネント 'R' の上にマウス カーソルを持っていって [r] を押してみてください。コンポーネントが回転します。回転させるためにコンポーネント上でクリックをする必要はありません。

    何か別のものの上にマウス カーソルがあった場合、時にはメニューが現れるでしょう。 明示的な選択メニューは KiCad ではしばしば見られ、互いに重なっているオブジェクトを選んで作業を可能にします。今回の場合、 'シンボル …​R…​' でアクションを実行することを KiCad に伝えます。
  10. コンポーネントの中央で右クリックして、 プロパティ定数を編集 を選択します。コンポーネントの上にマウス カーソルを持っていって、[v] を押すことでも同じ結果が得られます。代わりに [e] を押すと、もっと一般的なプロパティ ウィンドウが現れます。右クリック メニューには有効なアクションのホットキーが全て表示されていることに注目してください。

    Edit component menu
  11. 定数フィールドを編集のウィンドウが表示されます。

    リファレンス フィールド (R?) を変更しないで下さい。これは後ほど自動的に行われます。これで抵抗器の定数は '1 k' になりました。
    Resistor Value
  12. 別の抵抗器を配置するには、その抵抗器を置きたい場所で単にクリックだけして下さい。シンボルを選択のウィンドウが再び表示されます。

  13. 以前に選んだ抵抗器が履歴リスト上に 'R' として表示されています。OK をクリックしてコンポーネントを配置します。

    Component history
  14. 間違ったコンポーネントを削除したい場合、コンポーネント上で右クリックして 'コンポーネントを削除' をクリックします。これでコンポーネントは回路図から取り除かれます。あるいは、削除したいコンポーネント上にマウス カーソルを持っていき、[Delete] を押すことでも削除できます。

  15. 既に回路図シート上にあるコンポーネントにマウス カーソルを持っていき [c] を押すことで、複製することもできます。新しく複製したコンポーネントを置きたい場所でクリックして下さい。

  16. 2つ目の抵抗器の上で右クリックします。'ドラッグ’を選択します。コンポーネントを移動させて左クリックで確定します。コンポーネント上にマウス カーソルを持っていき [g] を押すことでも同じ機能を実行可能です。[r] はコンポーネントを回転させ、[x] と [y] は x 軸または y 軸に対してxコンポーネントを反転させます。

    右クリック移動 または [m] も同様に様々なものを移動させるのに役立つオプションですが、 コンポーネントのラベルと未接続コンポーネントにのみ使ったほうが良いでしょう。 なぜそうなのかは後述します。
  17. 2つ目の抵抗器にマウス カーソルを持っていき [v] を押して編集します。'R' を '100' で置き換えます。"Ctrl+Z" によってどんな編集操作も「元に戻す」ことができます。

  18. グリッドのサイズを変更します。回路図シート上では、全てのコンポーネントが広い間隔のグリッドにスナップされていることにお気付きのことでしょう。グリッドのサイズは 右クリックグリッド で簡単に変更できます。 概して回路図シートでは、50.0 ミル グリッドの使用をお勧めします。

  19. デフォルトのプロジェクトに設定されていないようなライブラリーからコンポーネントを追加してみましょう。メニューで、設定シンボル ライブラリーを管理 を選んで下さい。2つのタブ: グローバル ライブラリーとプロジェクト固有のライブラリー、を持つシンボル ライブラリーのウィンドウが表示されます。タブ各々が sym-lib-table ファイルを一つ持っています。有効なライブラリー (.lib file) は、これら sym-lib-table ファイルの一つに含まれていなければなりません。ファイル システムにライブラリー ファイルがあって未だ有効になっていなければ、 sym-lib-table ファイルのどちらかに追加することができます。練習として、既に有効になっているライブラリーを追加してみます。

  20. プロジェクト固有のテーブルを選択します。テーブルの下にあるライブラリーを参照ボタンをクリックします。あなたのコンピューターにインストールされている公式 KiCad ライブラリーの場所を見つける必要があります。多くの '.dcm' ファイルと '.lib' ファイルがある 'library' ディレクトリを探しましょう。 C:\Program Files (x86)\KiCad\share\ (Windows) や /usr/share/kicad/library/ (Linux) を見てみましょう。ディレクトリが見つかったら、 'MCU_Microchip_PIC12.lib' ライブラリーを選んで追加し、ウィンドウを閉じます。選んだライブラリーがリストの最後に追加されます。次にその別名(ニックネーム)をクリックして 'microchip_pic12mcu' に変更します。OK を押してシンボル ライブラリーのウィンドウを閉じて下さい。

  21. コンポーネント追加のステップを繰り返しますが、今度は 'Device' ライブラリーの代わりに 'microchip_pic12mcu' ライブラリーを選択して 'PIC12C508A-I/SN' コンポーネントを選びます。

  22. マイクロ コントローラーのコンポーネントにマウス カーソルを持っていきます。[x] と [y] がコンポーネントを反転させることに再び注目して下さい。G0 と G1 ピンが右を向くよう Y軸に沿ってシンボルを反転させたままにします。

  23. コンポーネント追加のステップを繰り返しますが、今度は 'Device' ライブラリーを選択して 'LED' コンポーネントを選びます。

  24. 回路図シート上の全てのコンポーネントを以下のように整理します。

    gsik_tutorial1_010_png
  25. 次に3ピンのコネクターとして 'MYCONN3' という回路図コンポーネントを作る必要があります。 「KiCad回路図シンボルの作成」 の章にジャンプし、一からコンポーネントを作る方法を学んでから、基板での学習を続けるためにこの章に戻ってきて下さい。

  26. さあ、新たに作成されたコンポーネントを配置することができるようになりました。[a] を押して 'myLib' ライブラリーにある 'MYCONN3' コンポーネントを選びます。

  27. コンポーネントの識別子 'J?' が 'MYCONN3' ラベルの下に現れるでしょう。その位置を変更したい場合は、'J?' の上で右クリックして 'リファレンスを移動' ( [m] と同等) をクリックします。これを行う前か最中にズーム インすると便利かもしれません。以下に示すようにコンポーネントの下に 'J?' を再配置します。ラベルは何回でも好きなだけ動かすことができます。

    gsik_myconn3_s_png
  28. 電源と GND のシンボルを配置します。右ツールバーにある '電源ポートを配置' ボタン add_power_png をクリックします。あるいは [p] を押します。コンポーネント選択のウィンドウで下方にスクロールし、 'power' ライブラリーから 'VCC' 選択します。OKをクリックして下さい。

  29. 1 k の抵抗器のピン上方をクリックして VCC を配置します。マイクロ コントローラー 'VDD' の上方をクリックします。 'コンポーネント選択履歴' から 'VCC' を選んで、VDD ピンの隣に配置します。再び追加作業を繰り返し、VCC を 'MYCONN3' の VCC ピンの上方に配置します。必要なら、リファレンスと定数を移動させておいて下さい。

  30. ピン追加のステップを繰り返しますが、今度は GND を選択します。GND を 'MYCONN3' GND ピンの下に配置します。別の GND シンボルをマイクロ コントローラの VSS ピンの左に配置します。回路図はこのようになっているはずです。:

    gsik_tutorial1_020_png
  31. 次に、全てのコンポーネントを配線します。右ツールバーの 'ワイヤーを配置' アイコン Place wire をクリックします。

    'バスを配置' を選ばないように注意しましょう。このボタンの直ぐ下にある太い線のアイコンです。 「KiCadでのバス接続」 の節でバスの使い方を説明しています。
  32. マイクロ コントローラ7ピンの端にある小さな円をクリックし、それから LED 1ピンの小さな円をクリックします。配線を曲げる時は一度クリックして下さい。接続しながらズーム インすることができます。

    配線されたコンポーネントを再配置したい場合、 [g] (掴む) を使うことが重要で、[m] (移動) を使うべきではありません。(掴む) を使うことでワイヤーの接続を維持できます。コンポーネントの移動方法を忘れたならステップ24を見直しましょう。
    gsik_tutorial1_030_png
  33. この処理を繰り返し、下のように他のコンポーネントの配線を全て済ませます。ワイヤーを終端するにはダブル クリックします。VCC と GND シンボルへの配線は、VCC シンボルなら下部、GND シンボルなら上部中央にタッチします。下のスクリーン ショットを見て下さい。

    gsik_tutorial1_040_png
  34. 今度はラベルを使って接続する別の方法を検討してみましょう。右ツールバーの 'ネット ラベルを配置' アイコン add_line_label_png をクリックし、ネット ラベル ツールを選びます。[l] を使うこともできます。

  35. マイクロ コントローラーの 6 ピンに接続されているワイヤーの中程をクリックします。このラベルに INPUT と名前をつけます。ラベルはまだ独立したアイテムで、例えば、動かしたり、回転させたり、削除することができます。ラベルの効果を生じさせるには、ラベルの小さな四角形のアンカーがワイヤーまたはピンの上に正確に存在しなければなりません。

  36. 同じ手順に従い、100Ωの抵抗器の右にある配線に別のラベルを配置します。同様に 'INPUT' と名前を付けます。同じ名前を持つ2つのラベルは、PIC のピン6と100Ω抵抗器の間に見えない接続を作ります。これは線が混雑した複雑なデザインの場合に便利な配線テクニックです。ラベルを配置するのに必ずしもワイヤは必要なく、単にピンにラベルを付けることもできます。

  37. ラベルはまた、単に配線に分かりやすい名前をつける目的で使うこともできます。例えば、PIC のピン7にラベルを付けて 'uCtoLED' と名前を入力します。抵抗器と LED 間のワイヤーに 'LEDtoR' と名前を付けたり、'MYCONN3' と抵抗器の間のワイヤーに 'INPUTtoR' と名前を付けるような使い方です。

  38. 接続されている電源オブジェクトからラベルが暗黙的に定義されているので、VCC と GND の線にラベルをつける必要はありません。

  39. 下図に最終的な結果がどのように見えるかを示します。

    gsik_tutorial1_050_png
  40. それでは接続されていないワイヤーに対処しましょう。接続されていないピンやワイヤーは KiCad のチェック時に警告されます。これらの警告を避けるため、ワイヤーが意図的に接続されていないことをプログラムに指示できます。

  41. 右ツールバーにある '空き端子フラグを配置' アイコン noconn_png をクリックします。ピン2、3、4、5をクリックします。 X は未接続が意図的であることを示すために表示されます。

    gsik_tutorial1_060_png
  42. 見えない電源ピンを持つコンポーネントがあります。左ツールバーの '非表示ピンを表示' アイコン hidden_pin_png をクリックすることでそれらを見えるようにできます。VCC と GND の名前は重要で、隠れた電源ピンは自動的に接続されます。一般的には、隠れた電源ピンを作らないように努力すべきです。

  43. ここで、どこかから供給される電源を KiCad に表示するための '電源フラグ' を追加する必要があります。[a] を押して 'power' ライブラリーにある 'PWR_FLAG' を検索して下さい。それらを2つ配置します。以下のように GND ピンと VCC に接続します。

    gsik_tutorial1_070_png
    これにより、この典型的な回路図チェックの警告を避けることができます: ピンは他のピント接続されていますが、このピンを起動するピンがありません
  44. 時には、いろいろな場所でコメントを書いておいたほうがいいこともあります。回路図にコメントを追加するには、右ツールバーにある 'テキストを配置' アイコン text_png を使います。

  45. ここで全てのコンポーネントにユニークな識別子を与える必要があります。実際、私達のコンポーネントの多くは未だ 'R?' や 'J?' と名付けられています。識別子の割り当ては、上部ツールバーにある '回路図シンボルをアノテーション' のアイコン annotate_png をクリックすることで自動的に行われます。

  46. '回路図をアノテーション' ウィンドウでは、 '全ての回路図を使用' を選択し、'アノテーション' ボタンをクリックします。次に確認メッセージで OK をクリックして、'閉じる' をクリックします。コンポーネントの全ての '?' が数字に置き換えられたことに注目してください。これで各識別子はユニークになりました。私達の例では、 'R1' 、 'R2' 、 'U1' 、 'D1' そして 'J1' と名付けられました。

  47. 次に回路図のエラーをチェックします。上部ツールバーの 'エレクトリカル ルールのチェックを実行' アイコン erc_png をクリックします。'実行' ボタンをクリックします。接続されていないワイヤー等のエラーや警告のレポートが通知されます。エラー0、警告0にしましょう。エラーや警告がある場合には、小さな緑色の矢印が回路図上のエラーや警告のある場所に表示されます 。よりエラーの情報を得るため 'ERC レポートファイルを生成' をチェックし、'実行' ボタンを再度押します。

    もし "デフォルトのエディタが指定されていません。エディタを指定して下さい。" の警告が出たなら、 C:\Windows\notepad.exe (Windows) か /usr/bin/gedit (Linux) を設定してみてください。
  48. ついに回路図が完成しました。これでコンポーネントに対応するフットプリントを付け足して、ネットリストのファイルを作成することができます。上部ツールバーにある 'ネットリストを生成' アイコン netlist_png をクリックして下さい。'生成' をクリックし、デフォルトのファイル名のままで '保存' をクリックします。

    KiCad の以前のバージョンでは、ネットリストが必須でした。 最近のバージョンでは、そうではなく、代わりに ツール回路図から基板を更新 を使うことができます。 これを実行する場合は、最初にフットプリントをシンボルに割り当てる必要があります。
  49. ネットリスト ファイルを生成したら、上部ツールバーにある 'Cvpcb を実行' アイコン cvpcb_png をクリックします。'ファイルが存在しません’のエラーが表示されたら、無視して OK をクリックします。

    シンボルにフットプリントを追加するには、もっと多くの方法があります。

    • シンボル上で右クリックし、 → プロパティフットプリントを編集 シンボル上でダブル クリック、あるいは右クリックし、→ プロパティプロパティを編集 → フットプリント

    • ツールシンボル フィールドを編集 回路図エディター (Eeschema) 一般オプションにある、シンボルの選択中にフットプリントをプレビュー をチェックし、 配置する新しいシンボルの選択時にフットプリントを選択

  50. Cvpcb は、回路図中の全てのコンポーネントに KiCad ライブラリーにあるフットプリントをリンクできます。中央のペインには、回路図で使用されている全てのコンポーネントが表示されます。ここで 'D1' を選択してみましょう。右側のペインには利用可能なフットプリントが全て現れるので、ここで下スクロールして 'LED_THT:LED-D5.0mm' の上でダブルクリックしてみて下さい。

  51. 右側のペインには、利用可能なフットプリントから選択されたサブ グループだけを表示することもできます。これは適切なフットプリントだけを KiCad に提示させるための手段です。これらのフィルターを有効、あるいは無効に切り替えるには、アイコン module_filtered_list_png, module_pin_filtered_list_png and module_library_list_png をクリックします。

  52. 'U1' には、フットプリント 'Package_DIP:DIP-8_W7.62mm' を選択します。'J1' には、フットプリント 'Connector:Banana_Jack_3Pin' を選択します。'R1' と 'R2' には、フットプリント 'Resistor_THT:R_Axial_DIN0207_L6.3mm_D2.5mm_P2.54mm_Vertical' を選択します。

  53. 選択したフットプリントがどのように見えるのか知りたければ、'選択したフットプリントを表示' アイコン show_footprint_png をクリックして、現在のフットプリントをプレビュー表示させることが出来ます。

  54. 割り当てが終わりました。ここで、ファイル回路図を保存 のクリックまたはボタン '適用して、回路図の保存&続行' で、回路図を保存することができます。

  55. Cvpcb を閉じて Eeschema 回路図エディターに戻ることが出来ます。Cvpcb で保存していなければ、ここで ファイル保存 をクリックし保存して下さい。再びネットリストを作成します。このネットリストは全てのフットプリントが更新されています。フットプリントが割り当てられていないデバイスがないように注意して下さい。ご自身でフットプリントを作ることになるでしょう。これについては、本ドキュメントの後の章で説明しています。

    この状態では全てのシンボルがフットプリントを割り当てられています。ネットリストと続く2つのステップに代わり、 ツール回路図から基板を更新 を使用できます。実行すると、Pcbnew が 回路図から基板を更新 ダイアログとともに開きます。ここからは、このチュートリアルにある Pcbnew の章での指示に従って進めることができます。
  56. KiCad プロジェクト マネージャーへと切り替えます。ファイル リストの中にネットリスト ファイルを見つけることができます。

  57. ネットリスト ファイルには、全てのコンポーネントとそのそれぞれのピン接続が記述されています。ネットリスト ファイルは、実際には容易に検査、編集や記載することのできるテキスト ファイルです。

    ライブラリー ファイル (*.lib) もテキスト ファイルで、同様に容易に編集したり記載することができます。
  58. 部品表 (BOM) を作成するには、Eeschema 回路図エディターを起動して上部ツールバーにある '部品表を生成' アイコン bom_png をクリックします。デフォルトでは、プラグインは全て無効になっています。 プラグインを追加 ボタンをクリックして一つ追加します。使いたい *.xsl ファイルを選択します。ここでは bom2csv.xsl を選択します。

    Linux:

    もし xsltproc が見つからない場合、ダウンロードして次のようにインストールします:

    sudo apt-get install xsltproc

    これは Ubuntu のような Debian 由来のディストリビューション用です。もしくは

    sudo yum install xsltproc

    これは RedHat 由来のディストリビューション用です。もし2種類のディストリビューション以外をお使いの場合は、お使いのディストリビューションのパッケージ マネージャー コマンドを使って xsltproc パッケージをインストールして下さい。

    xsl ファイルが置かれる場所: /usr/lib/kicad/plugins/.

    Apple OS X:

    もし xsltproc が見つからない場合、これを保存している Apple のサイトから Apple Xcode ツールをインストールするか、ダウンロードして次のようにインストールします:

    brew install libxslt

    xsl ファイルが置かれる場所: /Library/Application Support/kicad/plugins/.

    Windows:

    xsltproc.exe と含まれる xsl ファイルは、それぞれ <KiCad install directory>\bin<KiCad install directory>\bin\scripting\plugins に置かれます。

    全てのプラットホーム:

    最新の bom2csv.xsl はここから入手できます:

    KiCad は自動的にコマンドを生成します、例えば:
    xsltproc -o "%O" "/home/<user>/kicad/eeschema/plugins/bom2csv.xsl" "%I"
    拡張子を与えたい場合は、このコマンドラインを変更します:
    xsltproc -o "%O.csv" "/home/<user>/kicad/eeschema/plugins/bom2csv.xsl" "%I"

    更に情報を得るには、ヘルプ ボタンを押して下さい。

  59. では '生成' を押してみましょう。ファイル (プロジェクトと同じ名前です) はプロジェクト フォルダの中にあります。*.csv ファイルを LibreOffice Calc か Excel で開いてみましょう。インポートのウィンドウが表示されたら、OK を押します。

これであなたは次の章 "プリント基板のレイアウト" に進む準備ができました。ですが先に進む前に、コンポーネントのピンをバスで接続する方法をざっと見ておきましょう。

KiCad でのバス接続

時には、コンポーネント A の連続した幾つかのピンと、別のコンポーネント B の同様に連続したピンを接続しなければならないことがあります。この場合には2つの選択肢があります: 私達が既に見てきたラベルによる方法、あるいはバス接続の使用です。どのようにするのか見てみましょう。

  1. 4ピンのコネクターが3つあり、互いのピン同士を接続したいと仮定しましょう。コネクター P4 のピン4にラベルを付けるためにはラベル オプション ( [l] を押す) を使います。このラベルを 'a1' と名付けます。自動で同様にピン4の下のピン (ピン3) にレベルを追加するには [Insert] を押します。ラベルが自動的に 'a2' とリネームされることに注目しましょう。

  2. [Insert] を更に2回押して下さい。このキーは '最後のアイテムをリピート' 機能に対応しており、あなたの仕事を楽にしてくれるとても便利なコマンドです。

  3. ラベル付け作業を他の2つのコネクター CONN_2 と CONN_3 にも繰り返して終了します。このまま進めて基板を作成すると、3つのコネクターが互いに接続されているはずです。ここまで説明してきた結果を図2に示します。美しく見せるため、図3に示すように、アイコン Place wire to bus entry を使った一連の 'ワイヤ-バスエントリーを配置' とアイコン Place bus to bus entry を使ったバス ラインを付け加えることも可能です。基板には何も影響がないので付加しても特に差し支えありません。

  4. 図2のピンに接触している短いワイヤは厳密には不要であることを指摘しておきます。実際には、ラベルはピンに直接付けることができます。

  5. もう一歩進んで、4つ目のコネクタ CONN_4 を仮定します。何らかの理由により、そのラベル付け (b1, b2, b3, b4) は少し異なっています。私達は Bus aBus b をピンとピンの方法で接続したいのです。バス ラインへのラベル付けを、ピンにラベル付けする方法 (も可能ですが) を使わず、代わりにバス毎に1つのラベルで実現したいわけです。

  6. 前に説明したラベル付けの方法を使って、CONN_4 に接続してラベルを付けます。ピンには b1, b2, b3 そして b4 と名前を付けます。アイコン add_line2bus_png を使った一連の 'ワイヤ-バスエントリーを配置' と、アイコン add_bus_png を使ったバス ラインに、ピンを接続します。図4を見て下さい。

  7. CONN_4 のバスにラベルを付けて ( [l] キーを押して) 'b[1..4]' と名付けます。

  8. 以前のバスにラベルを付けて ( [l] を押して) 'a[1..4]' と名付けます。

  9. これでボタン add_bus_png を使って、バス a[1..4] とバス b[1..4] を接続することでできるようになりました。

  10. 2つのバスを接続することで、ピン a1 は自動的にピン b1 に接続され、a2 は b2 に接続され、以下同様となります。図4は最終結果がどのように見えるか示しています。

    [Insert] による '最後のアイテムをリピート' 機能は、繰り返される作業に上手く使うことができます。例えば、短いワイヤを全てのピンに接続する図2、図3、図4での作業はこの機能で実現できました。
  11. [Insert] による '最後のアイテムをリピート' 機能はまた、アイコン add_line2bus_png を使った、多くの連続した 'ワイヤ-バスエントリーを配置' にも適用できます。

    gsik_bus_connection_png

プリント基板のレイアウト

生成したネットリストのファイルを使ってPCBのレイアウトを行う時が来ました。これは Pcbnew ツールで行います。

Eeschema回路図から基板を更新 を使ったならば、ネットリストとステップ5は必要ありません。 ステップ6と7のように基板にフットプリントをドロップすることができ、それから図面情報とステップ2~4でのデザイン ルールを入力します。

Pcbnew の使用

  1. KiCad プロジェクト マネージャーで、'基板レイアウト エディター' (Pcbnew) アイコン pcbnew_png をクリックします。Eeschema から対応するツールバーのボタンを使うこともできます。'Pcbnew' のウィンドウが開きます。 「ボード *.kicad_pcb は存在しません。新規作成しますか?」というメッセージが出たら、'はい' をクリックします。

  2. いくつかの回路図情報を入力することから始めます。上部ツールバーの 'ページ設定' アイコン sheetset_png をクリックします。適切な 'ページ サイズ' ('A4'、'8.5x11' など) に設定して、 'タイトル' を 'Tutorial 1' と設定します。

  3. 基板メーカーが要求する クリアランス最少配線幅 に設定することから始めるのは良い考えです。一般的にクリアランスを '0.25'、最少配線幅を '0.25' に設定します。セットアップデザイン ルール メニューをクリックします。もし何も表示されていなければ 'ネットクラス エディター' のタブをクリックします。以下のように、ウィンドウ上部にある 'クリアランス' のフィールドを '0.25' に、 '配線幅' のフィールドを '0.25' に変更します。ここでの寸法は mm です。

    Design Rules Window
  4. 'グローバル デザイン ルール' タブをクリックし、 '最小配線幅' を '0.25' に設定します。変更を確定するには OK ボタンをクリックし、デザイン ルール エディターのウィンドウを閉じます。

  5. さあネットリスト ファイルをインポートしましょう。上部ツールバーにある 'ネットリストをロード' アイコン netlist_png をクリックします。Eeschema で作られたのであれば、'ネットリスト ファイル' フィールドにネットリスト ファイル 'tutorial1.net' が選択されていなければなりません。'現在のネットリストを読み込む' をクリックします。その後、'閉じる' ボタンをクリックします。

  6. 全てのコンポーネントが表示されるはずです。それらは選択されており、マウス カーソルと一緒に移動します。

  7. 基板の中央にコンポーネントを移動します。必要であれば、コンポーネントの移動中にズーム インやズーム アウトすることができます。マウスの左ボタンをクリックします。

  8. 全てのコンポーネントは ラッツネスト と呼ばれる細いワイヤの組で接続されています。'基板のラッツネストを非表示 (非表示)' ボタン general_ratsnest_png が押されていることを確認します。 これで全てのコンポーネントを接続しているラッツネストを見ることができます。

  9. コンポーネントにマウスカーソルを持っていき、[m] を押すことで移動できます。配置したい所でクリックして下さい。あるいはクリックしてコンポーネントを選んでからドラッグすることもできます。コンポーネントを回転させるには [r] を押して下さい。配線の交差数が最少になるまで、全てのコンポーネントを移動します。

    gsik_tutorial1_080_png
  10. 100Ω 抵抗器の一つのピンが PIC コンポーネントのピン6にどのように接続されているかに注目しましょう。これがピンを接続するのに使ったラベル付けによる方法の結果です。回路図の煩雑さを軽減できるので、しばしばラベルは実際にワイヤーで接続するよりも好まれます。

  11. 基板の外形を定義しましょう。上部ツールバーのドロップダウン メニューから 'Edge.Cuts' レイヤーを選択します。右ツールバーにある '図形ラインを追加' アイコン add_dashed_line_png をクリックします。基板の各コーナーをクリックして基板外形をトレースします。緑色のレジスト端と基板端の間には少し隙間を残すことを覚えておきましょう。

    Select the Edge.Cuts layer
  12. 次に GND を除く全てのワイヤーを接続します。実際のところ、基板裏側の銅箔 ( B.Cu と呼ばれます) に配置されたグラウンド面を使うことで、全ての GND 接続は纏めて接続されます。

  13. ここで作業する導体レイヤーを選択しなければなりません。上部ツールバーのドロップダウン メニューにある 'F.Cu (PgUp)' を選択します。これは表面の導体レイヤーです。

    Select the Front top copper layer
  14. 例えば、代わりに4層基板にすると決めたなら、 セットアップレイヤー セットアップ へ行って '導体レイヤー' を4に変更します。 'レイヤー' の表では、レイヤーに名前を付けて、用途を決めることができます。 'プリセット レイヤー グループ' メニューで選択可能な、便利なプリセットがあることを覚えておきましょう。

  15. 右ツールバーにある '配線' アイコン add_tracks_png をクリックします。 'J1' のピン1をクリックしてパッド 'R2' への配線を引きます。配線の終点を設定するには、ダブルクリックして下さい。この配線幅は、デフォルトの 0.250 mmになっています。上部ツールバーのドロップダウン メニューから配線幅を変更できます。デフォルトでは一つの配線幅しか利用できないことに注意して下さい。

    pcbnew_select_track_width_png
  16. 更に配線幅を追加したい場合は、セットアップデザイン ルールグローバル デザイン ルール タブと辿って、このウィンドウの右下にある表に利用したい配線幅を追加します。これで基板のレイアウト時にドロップダウン メニューから配線幅を選ぶことができるようになります。以下の例 (インチ単位) を参照して下さい。

    custom_tracks_width_png
  17. あるいは、指定したオプションのセットの中でネットクラスを追加することができます。 セットアップデザイン ルールネット クラス エディター を表示して 'power' という新しいクラスを追加します。配線幅を 8ミル (0.0080と表示) から 24ミル (0.0240と表示) に変更します。次に 'power' クラスに GND 以外の全てを追加します。(左で 'default' を選択、右で 'power' を選択、矢印を使います)

  18. グリッド サイズを変更したい場合は 右クリックグリッド と辿ります。コンポーネントを配置したり、配線で接続する前、或いは後に、状況に応じて適したグリッド サイズを選択するようにして下さい。

  19. J1 のピン3を除く全ての配線が終わるまで、この作業を繰り返します。あなたの基板は以下の例のようになるでしょう。

    gsik_tutorial1_090_png
  20. 基板の他の銅箔面で配線を行いましょう。上部ツールバーのドロップダウン メニューで 'B.Cu' を選択します。'配線' アイコン add_tracks_png をクリックします。J1 のピン3と U1 のピン8の間の配線を行って下さい。グラウンド面で接続することができるので、この配線は実際には必要ありません。配線の色が変わっていることに注目しましょう。

  21. レイヤーを変更して、ピン A からピン B に行きましょう。 ビアを配置することで、配線している銅箔面を変更できます。 表面の銅箔面に配線している時に、右クリックして 'ビアを配置' を 選ぶか単に [v] を押して下さい。これにより、配線を終えたところで 裏面レイヤーに移ります。

    place_a_via_png
  22. 特定の接続を検査したい場合は、右ツールバーにある 'ネットをハイライト' アイコン net_highlight_png をクリックします。J1 のピン3をクリックして下さい。配線そのものとそれに接続されている全てのパッドがハイライトされるでしょう。

  23. 全ての GND ピンに接続されるグラウンド面を作っていきます。右ツールバーにある '塗り潰しゾーンを追加' アイコン add_zone_png をクリックして下さい。基板の周囲に長方形を描くつもりで、角にしたいところに来たらクリックして下さい。表示されたダイアログでは、'デフォルトのパッド接続' を 'サーマル リリーフ' に、'外枠の角度' を '0, 45, 90度' に設定して、OK をクリックします。

  24. 順番にそれぞれの角でクリックして基板外形を描いていきます。最初の角に戻ったら再度クリックして長方形を完成させます。今、描いた領域の内側で右クリックして下さい。 'ゾーン'→'全て塗り潰し' をクリックします。基板は緑色に塗り潰され、このように見えるでしょう。:

    gsik_tutorial1_100_png
  25. 上部ツールバーにある 'デザイン ルール チェックを実行' アイコン erc_png をクリックして、デザイン ルール チェックを実行します。 'DRC を起動' をクリックして下さい。 エラーなしのはずです。 '未結線情報リスト' をクリックします。未接続のアイテムはないはずです。DRC ダイアログを閉じるには、OK をクリックします。

  26. ファイル保存 をクリックしてファイルを保存します。3Dで基板を閲覧するためには 表示3D ビューア をクリックします。

    pcbnew_3d_viewer_png
  27. PCBの周囲でマウスをドラッグしてPCBを回転させることができます。

  28. 基板はこれで完成です。メーカーに送るためにはガーバーファイルを生成する必要があります。

ガーバーファイルの生成

基板が完成したら、全てのレイヤーのガーバー ファイルを生成して、基板を製造してくれる、お好みの基板メーカーに送ることができます。

  1. KiCad から、Pcbnew 基板エディターを開きます。

  2. ファイルプロット をクリックして下さい。 '出力フォーマット' として 'ガーバー' を選択し、ガーバー ファイルを保存するフォルダを選択します。 '製造ファイル出力' ボタンを押して出力します。

  3. ドリルファイルを生成するには、 Pcbnew から ファイルプロット を再び行います。デフォルトの設定でよいでしょう。

  4. これらは典型的な2層PCBを製造するために選択する必要があるレイヤです:

レイヤー KiCad レイヤー名 デフォルトのガーバー拡張子 "Protel の拡張子を使用" が有効な場合

裏面導体レイヤー

B.Cu

.GBR

.GBL

表面導体レイヤー

F.Cu

.GBR

.GTL

表面シルク面

F.SilkS

.GBR

.GTO

裏面ハンダ マスク

B.Mask

.GBR

.GBS

表面ハンダ マスク

F.Mask

.GBR

.GTS

基板外形

Edge.Cuts

.GBR

.GM1

GerbView の使用

  1. 全てのガーバー ファイルを見るには、KiCad プロジェクト マネージャーに行って、'GerbView' アイコンをクリックします。ドロップダウン メニューまたはレイヤー マネージャーで、'グラフィック レイヤー 1' を選択します。ファイルガーバー ファイルを開く をクリックするか、アイコン gerber_file_png をクリックします。選択して、生成された全てのガーバー ファイルを開きます。それら全てが積み重なって表示されることに着目して下さい。

  2. ファイルExcellon ドリル ファイルを開く と辿って、ドリル ファイルを開きます。

  3. 表示するレイヤーを選択/非選択にするには、右側にあるレイヤー マネージャーを使用します。メーカーに送る前に各レイヤーを注意深く検査しましょう。

  4. 表示は Pcbnew と同様です。グリッドを変更するには、表示領域内で右クリックして 'グリッド' をクリックして下さい。

FreeRouter による自動配線

基板の手配線は早くて楽しいですが、大量のコンポーネントを含む基板の場合には自動配線を使いたくなるかもしれません。最初に手配線で重要な配線を行ってから、うんざりするような仕事を自動配線にセットすべきだということを覚えておいて下さい。自動配線は未配線にだけ働きます。ここで私達が使う自動配線ツールは、 FreeRouting です。

FreeRouting はオープン ソースの java アプリケーションです。今のところ FreeRouting は、 "freerouting" でインターネットを検索すると見つかる、幾つかのほとんど同一のコピーとして存在しています。 ソース コードのみ、あるいはプリコンパイルされた java パッケージとして見つけられるでしょう。
  1. PcbnewファイルエクスポートSpecctra DSN をクリックし、ローカルにファイルを保存します。FreeRouter を起動して、 'Open Your Own Design' ボタンをクリックし、dsn ファイルを選んで読み込ませます。

  2. FreeRouter は、手配線と自動配線の両方で、KiCad が現時点で持っていない特徴を持っています。FreeRouter は2つの主要なステップで操作します: 最初に基板に配線を行い、次にそれを最適化します。完全最適化には時間がかかるかもしれませんが、必要ならいつでも停止することができます。

  3. 上部ツールバーにある 'Autorouter' ボタンをクリックすることで自動配線を開始できます。下部のバーは実行中の配線作業の情報を知らせてくれます。もしも 'Pass' カウントが30以上になったら、あなたの基板はおそらくこのルーターでは自動配線できないでしょう。コンポーネント間隔をもっと広げたり良い向きに回転させてから再挑戦しましょう。部品の回転と位置決めのゴールは、ラッツネストの空中交差の数を少なくすることです。

  4. マウスの左クリックにより、自動配線を停止して最適化プロセスを自動的に開始させることができます。もう一度左クリックすると、最適化プロセスが停止します。停止する必要がないのであれば、FreeRouter が仕事を終えるのに任せるのが良いでしょう。

  5. FileExport Specctra Session File メニューをクリックして基板ファイルを .ses 拡張子で保存します。FreeRouter ルール ファイルは保存する必要ありません。

  6. Pcbnew に戻りましょう。 ファイルインポートSpectra Session をクリックして .ses ファイルを選択すると、新たに配線された基板をインポートすることができます。

もし気に入らない配線があれば、配線を削除して再配線できます。 [Delete] と、右ツールバーにある '配線' アイコン Add Track icon の配線ツールを使いましょう。

KiCad のフォワード アノテーション

電気回路図、フットプリントの割り当て、基板レイアウト、ガーバー ファイルの生成を完了すると、基板を実際に作る基板メーカーに全てを送る準備が整います。

しばしば、この線形の作業の流れは一方向ではなくなります。例えば、既にこの作業の流れを完了していたはずの基板を変更/拡張しなければならない時ですが、あなたは、部品を動かしたり、他のものと入れ替えたり、部品を変更したり、等々する必要が起こりえます。この変更の作業の中で、あなたがやりたくないことは基板全体を一から配線し直すことでしょう。代わりにこのようにすべきです:

  1. 仮想的なコネクタのCON1をCON2と入れ替えたいと想定しましょう。

  2. あなたは既に完成した回路図と配線を終えたPCBを持っています。

  3. KiCad から Eeschema を起動して、CON1を削除しCON2を追加して変更を行います。アイコン Save icon で回路図プロジェクトを保存して、上部ツールバーにある 'ネットリストの生成' のアイコン netlist_png をクリックします。

  4. 'ネットリスト' をクリックし '保存' します。デフォルトのファイル名で保存しましょう。古いファイルを上書きします。

  5. CON2にフットプリントを割り当てます。上部ツールバーにある 'CvPcb(コンポーネントとフットプリントの関連付け)を実行' のアイコン cvpcb_png をクリックします。新しいデバイスのCON2にフットプリントを割り当てます。残りのコンポーネントは以前に割り当てたフットプリントのままです。 CvPcb を閉じます。

  6. Eeschema に戻り、 'ファイル' → '回路図プロジェクトの保存' をクリックしてプロジェクトを保存します。 Eeschema を閉じます。

  7. KiCadプロジェクト・マネージャから 'Pcbnew' のアイコンをクリックします。 'Pcbnew' のウィンドウが開きます。

  8. 古い、配線済みの基板が自動的に開きます。新しいネットリストファイルをインポートしましょう。上部ツールバーにある 'ネットリストの読込み' のアイコン netlist_png をクリックします。

  9. 'ネットリストファイルを参照する' ボタンをクリックして、ネットリストファイルを選択し、 '現在のネットリストを読み込む' をクリックします。そして '閉じる' ボタンをクリックします。

  10. この時点で、以前の全ての部品が配線済みのレイアウトが見られます。左上の隅に全ての未配線の部品、今回の例ではCON2が見えるでしょう。マウスでCON2を選択します。基板の中央まで移動しましょう。

  11. CON2を配置して配線します。完了したらいつものように保存してガーバーファイルの生成をしましょう。

ここに書いた手順は必要に応じて何度でも容易に繰り返すことが可能です。上述したフォワード・アノテーションとは別に、バック・アノテーションとして知られる別の方法があります。この方法はPcbnewで配線済みにした基盤の変更を、回路図とネットリストに反映することを可能にします。が、バック・アノテーションはそんなに便利ではないのでここでは書きません。

KiCad 回路図シンボルの作成

時には、回路図に配置したいシンボルが KiCad のライブラリの中にないことがあります。これは当たり前のことで嘆くことではありません。この章では、新しい回路図シンボルが KiCad でいかに素早く作れるのかを見ていきましょう。しかし、KiCad のコンポーネントはいつでもインターネット上で見つけられることも覚えておきましょう。

KiCad では、シンボルは DEF で始まり ENDDEF で終わるテキストの断片です。通常は一つ以上のシンボルが拡張子 .lib のライブラリー ファイルに含まれています。シンボルをライブラリー ファイルに追加したければ、テキスト エディターのカット&ペースト コマンドを使うだけです。

コンポーネント ライブラリ エディターの使用

  1. 新しいコンポーネントの作成には コンポーネント・ライブラリ・エディタ (Eeschema の一部) を使います。プロジェクトフォルダ 'tutorial1' 内に 'library' というフォルダを作りましょう。新コンポーネントを作ったら、そこに新しいライブラリファイル myLib.lib を置きます。

  2. さあ新しいコンポーネントの作成を始めましょう。KiCadから Eeschema を起動して、'コンポーネント・ライブラリ・エディタ' のアイコン libedit_png をクリックし、'新規コンポーネント作成' のアイコン new_component_png をクリックします。コンポーネント・プロパティのウィンドウが現れます。新しいコンポーネントを 'MYCONN3' と名付け、'デフォルトのリファレンス記号' を 'J' に、'パッケージ内のユニット数' を '1' に設定します。OKをクリックします。警告が出たらyesをクリックしておきます。 この時点ではコンポーネントは、そのラベルだけで構成されています。ピンをいくつか足してみましょう。右ツールバーにある 'コンポーネントにピンを追加' のアイコン pin_png をクリックします。ピンを配置するには、シートの 'MYCONN3' ラベルの下あたりを左クリックします。

  3. 現れた 'ピンのプロパティ' ウィンドウで、ピン名を 'VCC' 、ピン番号を '1' 、'エレクトリック・タイプ' を '電源入力' に設定してOKをクリックします。

    Pin Properties
  4. 適当な場所、 'MYCONN3' ラベルの右下あたり、をクリックしてピンを配置します。

  5. ピン配置のステップを繰り返します。今度は 'ピン名' は 'INPUT' で、 'ピン番号' は '2' で、 'エレクトリックタイプ' は 'パッシブ' とします。

  6. ピン配置のステップを繰り返します。今度は 'ピン名' は 'GND' で、 'ピン番号' は '3' で、 'エレクトリックタイプ' は 'パッシブ' とします。ピンを順に重ねて配置します。コンポーネントのラベルの 'MYCONN3' をページの中心(青いラインが交差する所)にします。

  7. 次にコンポーネントの輪郭を描きましょう。 'コンポーネントのボディに矩形を入力' のアイコン add_rectangle_png をクリックします。以下に示すようにピンに隣接して長方形を描きます。まず、長方形の左上の角にしたい所をクリックします(マウスボタンを押したままにしません)。そして、長方形の右下の角にしたい所をクリックします。

    gsik_myconn3_l_png
  8. 矩形を黄色で塗りつぶしたい場合、まず 設定色の設定 で "ボディ背景色" を "黄色 4" に設定します。そして、編集画面上で塗りつぶしたい矩形の枠上にマウスカーソルを置いて [e] を押して 図形のプロパティ ウィンドウを表示し、 '背景色で塗りつぶし' を選択します。

  9. コンポーネントをあなたのライブラリ myLib.lib に保存しましょう。 '新しいライブラリへ現在のコンポーネントを保存' のアイコン new_library_png をクリックして、フォルダ tutorial1/library/ を選び、新しいライブラリファイルを myLib.lib という名前で保存します。

  10. 設定コンポーネントライブラリ で、 tutorial1/library/ を 'ユーザ定義の検索パス' に追加し、 myLib.lib を 'コンポーネントライブラリファイル' に追加します。

  11. '作業ライブラリの選択' のアイコン library_png をクリックします。ライブラリの選択ウィンドウ内で myLib を選択してOKをクリックします。ウィンドウの上部が現在使用中のライブラリを示しており、それが myLib であることに注意しましょう。

  12. 上部ツールバーにある '現在のライブラリ内の現在のコンポーネントを更新' のアイコン save_part_in_mem_png をクリックします。上部ツールバーにある 'ディスクに現在のライブラリを保存' のアイコン save_library_png をクリックして変更を全て保存します。どの確認メッセージにも 'はい' をクリックして下さい。新しい回路図コンポーネントは完成して、ウィンドウのタイトルバーに示されているライブラリから使えます。

  13. コンポーネント・ライブラリ・エディタのウィンドウを閉じます。 Eeschema のウィンドウに戻ります。あなたの新しいコンポーネントはライブラリ myLib から利用できます。

  14. ライブラリパスに追加することによって、ライブラリの file.lib ファイルを利用できるようになります。 Eeschema から 設定コンポーネントライブラリ として、それへのパスを 'ユーザ定義の検索パス' に追加し、 file.lib を 'コンポーネントライブラリファイル' に追加します。

コンポーネントのエクスポート、インポート、変更

一からコンポーネントを作るよりも、既に作られたものから始めてそれを変更する方が簡単なこともあります。この章では、KiCadの標準ライブラリ 'device' から、あなた独自のライブラリ myOwnLib.lib にコンポーネントをエクスポートして、それを変更する方法を見ていきましょう。

  1. KiCadから Eeschema を起動して、 'コンポーネント・ライブラリ・エディタ' のアイコン libedit_png をクリックして、 '作業ライブラリの選択' のアイコン library_png をクリックし、 'device' ライブラリを選びます。 '現在のライブラリからエディタへコンポーネントを読み込む' のアイコン import_cmp_from_lib_png をクリックして 'RELAY_2RT' をインポートします。

  2. 'コンポーネントのエクスポート' のアイコン export_png をクリックして、フォルダ library/ へ行き、新しいライブラリファイルを myOwnLib.lib という名前で保存します。

  3. ライブラリパスに追加することで、このコンポーネントとライブラリ全体 myOwnLib.lib が利用できるようになります。 Eeschema から 設定コンポーネントライブラリ として、 library/ を 'ユーザ定義の検索パス' に追加し、 myOwnLib.lib を 'コンポーネントライブラリファイル' に追加します。追加したら "OK" ボタンを押してウィンドウを閉じます。

  4. '作業ライブラリの選択' のアイコン library_png をクリックします。ライブラリの選択ウィンドウ内で myOwnLib を選択してOKをクリックします。ウィンドウの上部が現在使用中のライブラリを示しており、それが myOwnLib であることに注意しましょう。

  5. '現在のライブラリからエディタへコンポーネントを読み込む' のアイコン import_cmp_from_lib_png をクリックして 'RELAY_2RT' をインポートします。

  6. これでコンポーネントを好きなように変更できます。マウスカーソルをラベル 'RELAY_2RT' に重ねて [e] を押して 'MY_RELAY_2RT' にリネームします。

  7. 上部ツールバーにある '現在のライブラリ内の現在のコンポーネントを更新' のアイコン save_part_in_mem_png をクリックします。上部ツールバーにある 'ディスクに現在のライブラリを保存' のアイコン save_library_png をクリックして変更を全て保存します。

quicklibによる回路図コンポーネントの作成

この章では、インターネットのツール quicklib を使った、回路図コンポーネント MYCONN3 (前の 「MYCONN3」 参照) の別の作成方法を紹介します。

  1. quicklib のウェブページに行きましょう: http://kicad.rohrbacher.net/quicklib.php

  2. ページに次の情報を入力しましょう: Component name: MYCONN3、 Reference Prefix: J、 Pin Layout Style: SIL、 Pin Count, N: 3

  3. 'Assign Pins' をクリックします。ページに次の情報を入力しましょう: Pin 1: VCC、 Pin 2: input、 Pin 3: GND 。Type は3つのピンとも Passive を選択します。

  4. 'Preview' をクリックします。満足なら 'Build Library Component' をクリックします。 ファイルをダウンロードして tutorial1/library/myQuickLib.lib と名付けます。できました!

  5. それをKiCadを使って見てみましょう。KiCadプロジェクト・マネージャから Eeschema を起動して、 'コンポーネント・ライブラリ・エディタ' のアイコン libedit_png をクリックし、 'コンポーネントのインポート' のアイコン import_png をクリックし、 tutorial1/library/ へ行き myQuickLib.lib を選択します。

    gsik_myconn3_quicklib_png
  6. ライブラリパスに追加することで、このコンポーネントとライブラリ全体 myQuickLib.lib が利用できるようになります。 Eeschema から 設定コンポーネントライブラリ として、 library/ を 'ユーザ定義の検索パス' に追加し、 myQuickLib.lib を 'コンポーネントライブラリファイル' に追加します。

このコンポーネント作成方法は、たくさんのピンを持つコンポーネントを作りたい時に非常に効果的であると想像できるでしょう。

大量ピンの回路図コンポーネントの作成

quicklibによる回路図コンポーネントの作成 の章で、ウェブベースのツール quicklib を使った回路図コンポーネントの作成方法を見ました。しかし、時に、大量ピン(数百のピン)を持つ回路図コンポーネントを作る必要があることに気付くでしょう。KiCadでは、これはそんなにややこしい仕事ではありません。

  1. 50ピンのデバイスのための回路図コンポーネントを作成したいとします。複数の少量ピンの図形、例えば25ピンの図形を2つ、を使ってそれを描くのが一般的な方法です。このコンポーネント表現はピン接続が容易でしょう。

  2. このコンポーネントを作成する最良の方法は、quicklib を使って別々に25ピンのコンポーネントを生成して、Pythonスクリプトでそれらのピン番号を振り直し、最終的に2つを統合して一組のDEFとENDDEFの中にコピー&ペーストすることです。

  3. 以下に in.txt ファイルと out.txt ファイルと連動して使えるシンプルなPythonスクリプトの例を示します。これは in.txt ファイルの中の全ての行に対して、 X PIN1 1 -750 600 300 R 50 50 1 1 I を X PIN26 26 -750 600 300 R 50 50 1 1 I のように数字の振り替えをします。

シンプルなスクリプト
#!/usr/bin/env python
''' simple script to manipulate KiCad component pins numbering'''
import sys, re
try:
    fin=open(sys.argv[1],'r')
    fout=open(sys.argv[2],'w')
except:
    print "oh, wrong use of this app, try:", sys.argv[0], "in.txt out.txt"
    sys.exit()
for ln in fin.readlines():
    obj=re.search("(X PIN)(\d*)(\s)(\d*)(\s.*)",ln)
if obj:
    num = int(obj.group(2))+25
    ln=obj.group(1) + str(num) + obj.group(3) + str(num) + obj.group(5) +'\n'
    fout.write(ln)
fin.close(); fout.close()
#
# for more info about regular expression syntax and KiCad component generation:
# http://gskinner.com/RegExr/
# http://kicad.rohrbacher.net/quicklib.php
  1. 2つのコンポーネントを一つに統合するために、 Eeschema からコンポーネント・ライブラリ・エディタを使って、1番目のコンポーネントを移動し、2番目に重ならないようにしてやる必要があるでしょう。以下に最終的な .lib ファイルとその Eeschema での表現を示します。

*.lib ファイルの内容
Eeschema-LIBRARY Version 2.3
#encoding utf-8
# COMP
DEF COMP U 0 40 Y Y 1 F N
F0 "U" -1800 -100 50 H V C CNN
F1 "COMP" -1800 100 50 H V C CNN
DRAW
S -2250 -800 -1350 800 0 0 0 N
S -450 -800 450 800 0 0 0 N
X PIN1 1 -2550 600 300 R 50 50 1 1 I

...

X PIN49 49 750 -500 300 L 50 50 1 1 I
ENDDRAW
ENDDEF
#End Library
gsik_high_number_pins_png
  1. ここで紹介しているPythonスクリプトは、ピン番号とピンラベルを操作するとても強力なツールです。その威力は、難解ではありますが驚くほどに便利な正規表現構文による、ということを覚えておいて下さい: http://gskinner.com/RegExr/

フットプリントの作成

他の、一種類のライブラリに回路図記号とフットプリントの両方を含むEDAソフトウェア・ツールと異なり、KiCadの .lib ファイルは回路図記号を、 .kicad_mod ファイルはフットプリントを含んでいます。 CvPcb は回路図記号にフットプリントを割り当てるのに使われます。

.lib と同様に、 .kicad_mod ファイルはテキストファイルで、一つのフットプリントを含むことができます。

KiCadには豊富なフットプリントのライブラリがありますが、あなたが必要とするフットプリントがKiCadのライブラリ内にないこともあるでしょう。ここではKiCadで新しいPCBフットプリントを作成する手順を示します:

フットプリント・エディタの使用

  1. KiCadプロジェクト・マネージャから Pcbnew ツールを起動します。上部ツールバーにある 'フットプリント エディタを開く' のアイコン edit_module_png をクリックします。 'フットプリント・エディタ' が開きます。

  2. 新しいフットプリント ライブラリー 'myfootprint' に新規フットプリント 'MYCONN3' を保存します。tutorial1/ プロジェクト フォルダーに新しいフォルダー myfootprint.pretty/ を作成して下さい。 設定フットプリント ライブラリーを管理 をクリックし、'ライブラリーを追加' ボタンを押します。テーブルで、別名 (ニックネーム) には "myfootprint" 、ライブラリーのパスには "${KIPRJMOD}/myfootprint.pretty"、プラグインの種類には "KiCad" を入力します。ライブラリー テーブルのウィンドウを閉じるには OK を押して下さい。上部ツールバーの 'アクティブなライブラリーを選択' アイコン library_png をクリックします。'myfootprint' ライブラリーを選択して下さい。

  3. 上部ツールバーにある '新規フットプリント' のアイコン new_footprint_png をクリックします。 'フットプリント名' に 'MYCONN3' を入力します。画面中央に 'MYCONN3' ラベルが表示されます。そのラベルの下に 'REF*' があります。 'MYCONN3' の上で右クリックし、 'REF' の上方に移動します。 'REF*' 上で右クリックして、 'テキストの編集' を選び、 'SMD' にリネームします。テキストプロパティの '表示' の項目で '非表示' を選択します。

  4. 右ツールバーにある 'パッドを追加' のアイコン pad_png を選択します。パッドを配置するため画面をクリックします。新しいパッド上で右クリックし 'パッドを編集' をクリックします。代わりに [e] も使えます。

    Pad Properties
  5. 'パッド番号' を '1' に、 '形状' を '四角' に、 'パッド形状' を 'SMD' に、 'サイズX' を '0.4' に、 'サイズY' を '0.8' に設定し、OKをクリックします。再度 'パッド入力' をクリックし、 もう2つパッドを配置します。

  6. グリッドサイズを変更したいなら 右クリックグリッドの選択 とします。配置する前に適切なグリッドサイズを選択しましょう。

  7. 上の図のように 'MYCONN3' と 'SMD' のラベルを外側に移動します。

  8. パッドを配置する時には、相対的な距離を測る必要があります。相対座標軸の (0,0) としたい所にカーソルを置き、スペースキーを押します。カーソルを動かすと、カーソル位置の相対的な指標がウィンドウの下方に見えるでしょう。新しい原点を設定するにはスペースキーを押しましょう。

  9. フットプリントの輪郭を加えましょう。右ツールバーにある '図形ライン(またはポリゴン)を入力' のボタン add_polygon_png をクリックします。パーツの周囲にコネクタの外形を描きます。

  10. 上部ツールバーにある 'アクティブなライブラリへフットプリントを保存' のアイコン save_library_png をクリックし、デフォルト名のMYCONN3で保存します。

KiCadプロジェクトファイルの可搬性について

あなたのKiCadプロジェクトを、他の人が完全に取り込んで使えるために、どのファイルを送る必要があるでしょうか?

誰かとKiCadのプロジェクトを共有する時、回路図ファイル .sch 、基板ファイル .kicad_pcb 、プロジェクトファイル .pro 、ネットリストファイル .net を、コンポーネントライブラリファイル .lib 及びフットプリントライブラリファイル .kicad_mod と一緒に送ることが重要です。この方法でのみ完全に自由に回路図と基板を変更することができます。

KiCadの回路図では、回路図記号を含む .lib ファイルが必要です。それらのライブラリファイルは Eeschema の設定で読み込まれる必要があります。一方、基板( .kicad_pcb ファイル)では、フットプリントは .kicad_pcb ファイルの中に保存させることができます。誰かに .kicad_pcb ファイルだけを送っても、彼はその基板を見たり編集したりできるわけです。しかし、もし彼がネットリストからコンポーネントを読み込みたいのであれば、フットプリントライブラリ (.kicad_mod ファイル) が存在し、回路図の場合と同様に、 Pcbnew の設定で読み込まれている必要があります。同様に、 CvPcb でモジュールが表示されるようにするためには、 Pcbnew の設定で .kicad_mod ファイルが読み込まれていることが必要です。

もし誰かが フットプリント付きの .kicad_pcb ファイルを送ってくれたら、あなたはそれを他の基板でも利用したいでしょう。フットプリント・エディタを開き、現在の基板からフットプリントを読み込み、保存するか別のフットプリント・ライブラリ・ファイルにエクスポートします。 .kicad_pcb ファイルから全てのフットプリントを一度にエクスポートすることもできます。 Pcbnewファイルフットプリントのアーカイブフットプリントアーカイブの作成 で、基板上の全てのフットプリントの .kicad_mod ファイルが生成されます。

結論として、PCBだけを配布したいのなら、基板ファイル .kicad_pcb だけで十分です。しかし、あなたが他の人に、回路図と部品と基板の、利用と変更の完全な自由を与えたいのならば、以下のプロジェクトディレクトリをzipして送ることをお勧めいたします。

tutorial1/
|-- tutorial1.pro
|-- tutorial1.sch
|-- tutorial1.kicad_pcb
|-- tutorial1.net
|-- library/
|   |-- myLib.lib
|   |-- myOwnLib.lib
|   \-- myQuickLib.lib
|
|-- myfootprint.pretty/
|   \-- MYCONN3.kicad_mod
|
\-- gerber/
    |-- ...
    \-- ...

KiCadドキュメントの詳細

この文書はKiCadの大部分の機能のクイックガイドでした。より詳細な手順については、それぞれのKiCadツールから参照できるヘルプファイルを参照して下さい。 ヘルプマニュアル をクリックです。

KiCadには、その4つのソフトウェアコンポーネント全てに、とても良い多言語のマニュアルが付いてきます。

全KiCadマニュアルの英語版はKiCadと一緒に配布されます。

マニュアルに加えて、KiCadはこの、他の言語にも翻訳されたチュートリアルと一緒に配布されます。このチュートリアルは無料で最新版のKiCadと共に配布されます。このチュートリアルとマニュアルはご利用のKiCadと共にパッケージされています。

Linux の場合、ディストリビューションにもよりますが、一般的に次のディレクトリでしょう:

/usr/share/doc/kicad/help/en/
/usr/local/share/doc/kicad/help/en

Windows の場合:

<installation directory>/share/doc/kicad/help/en

OS X の場合:

/Library/Application Support/kicad/help/en

Web上のKiCadドキュメント

最新のKiCadのドキュメンテーションは、複数の言語に翻訳されてWeb上にあります。