Руководство пользователя

Авторские права © 2010-2018 на данный документ принадлежит его разработчикам (соавторам), перечисленным ниже. Документ можно распространять и/или изменять в соответствии с правилами лицензии GNU General Public License (http://www.gnu.org/licenses/gpl.html), версии 3 или более поздней, или лицензии типа Creative Commons Attribution License (http://creativecommons.org/licenses/by/3.0/), версии 3.0 или более поздней.

Все торговые знаки этого руководства принадлежат его владельцам.

Соавторы

The KiCad Team

Перевод

KiCad Russian Team
alex9 <gmdii@mail.ru>
Барановский Константин <baranovskiykonstantin@gmail.com>, 2019

Обратная связь

Оставить свои комментарии или замечания можно на следующих ресурсах:

Дата публикации

24 февраля 2018 года.

Знакомство c GerbView

GerbView предназначен для просмотра файлов в формате Gerber (RS 274 X) и отображения файлов сверловки из Pcbnew (в формате Excellon). Одновременно может быть показано до 32 файлов.

Для получения дополнительной информации о формате файлов Gerber воспользуйтесь спецификацией the Gerber File Format Specification. Информацию о формате файла сверловки можно получить здесь the Excellon format description.

Графический интерфейс

Основное окно

gerbview_main_screen_png

Верхняя панель инструментов

gerbview_top_toolbar_png

delete_gerber_png

Clear all layers

load_gerber_png

Load Gerber files

gerbview_drill_file_png

Load Excellon drill files

sheetset_png

Set page size

print_button_png

Print

zoom_redraw_png

Redraw view

zoom_in_png zoom_out_png

Zoom in or out

zoom_fit_in_page_png

Zoom auto (zoom fit)

zoom_area_png

Zoom to selection

gerbview_top_layer_png

Select active layer

gerbview_top_info_png

Display info about active layer

gerbview_x2_component_png

Highlight items belonging to selected component (Gerber X2)

gerbview_x2_net_png

Highlight items belonging to selected net (Gerber X2)

gerbview_x2_attributeo_png

Highlight items with the selected attribute (Gerber X2)

gerbview_top_dcode_png

Highlight items of selected D Code on the active layer

Левая панель инструментов

gerbview_left_toolbar_png

cursor_png

Select items

measurement_png

Measure between two points

grid_png

Toggle grid visibility

polar_coord_png

Toggle polar coordinates display

unit_inch_png unit_mm_png

Select inch or millimeter units

cursor_shape_png

Toggle full-screen cursor

pad_sketch_png

Display flashed items in sketch (outline) mode

track_sketch_png

Display lines in sketch (outline) mode

opt_show_polygon_png

Display polygons in sketch (outline) mode

gerbview_show_negative_objects_png

Show negative objects in ghost color

show_dcodenumber_png

Show/hide D Codes

gbr_select_mode2_png

Display layers in diff(compare) mode

contrast_mode_png

Display current layer in high-contrast mode

layers_manager_png

Show/hide layer manager

Менеджер слоёв

gerbview_layer_manager_png

Менеджер слоёв позволяет управлять и контролировать видимость всех слоёв. Стрелка указывает на активный слой, а с помощью отметок можно скрыть или показать нужные слои.

Функции кнопок мыши:

  • Щелчок левой кнопкой мыши на строке: выбор активного слоя.

  • Щелчок правой кнопки мыши на менеджере слоёв: управление отображением сразу всех слоёв.

  • Щелчок средней кнопкой мыши или двойной щелчок (на индикаторе цвета): выбор цвета слоя.

Вкладка Слои позволяет управлять отображением и цветом всех загруженных Gerber-слоёв или слоёв сверловки. Вкладка Элементы позволяет управлять отображением и цветом сетки, D-кодов и негативных объектов.

Команды меню

Меню "Файл"

gerbview_file_menu_png
  • Экспорт в Pcbnew имеет ограниченные возможности для экспорта Gerber-файлов в Pcbnew. Конечный результат зависит от того, какие особенности формата RS 274 X используются в Gerber-файлах: растровые элементы (в основном, негативные объекты), не могут быть преобразованы; элементы, заданные командой Gerber "засветка", преобразуются в переходные отверстия; элементы, заданные командой Gerber "линия", преобразуются в отрезки (или в графические линии для не медных слоев)

Меню "Настройки"

gerbview_preferences_menu_png

Режимы отображения

GerbView теперь поддерживает современный режим отображения грфики, который используется в PcbNew. Активация данного режима позволяет использовать новые инструменты и работать с лучшей производительностью. Можно выбрать желаемый режим отображения через меню настроек. Если видеоадаптер поддерживает OpenGL 2.0, рекомендуется использовать Современный инструментарий (ускоренный). Если же ведеоадаптер не имеет графического ускорителя, можно работать с новыми инструментами в режиме Современноый инструментарий (запасной).

Использование Устаревшего инструментария рекомендуется только в том случае, если современные режимы отображения не имеют небходимых инструментов или содержимое Gerber-файлов отображается не корректно. Если возникает подобная проблема, будьте добры, сообщите об этом разработчиками KiCad, чтобы они смогли устранить это в будущих выпусках.

Устаревший режим отображения в будщих версиях GerbView будет удалён.

Меню "Разное"

gerbview_misc_menu_png
  • Список D-кодов показывает используемые D-коды и некоторые их параметры.

  • Показать содержимое файла отображает содержимое Gerber-файла активного слоя в текстовом редакторе.

  • Очистить текущий слой стирает содержимое активного слоя.

  • Выбор текстового редактора…​ позволяет выбрать приложение для просмотра содержимого файлов.

Режимы отображения слоёв

GerbView имеет три режима отображения, которые будут полезны в различных ситуациях и при разных условиях.

"Пакетный" и "прозрачный" режимы обеспечивают наилучшее качество отображения, но на некоторых компьютерах, могут работать медленнее чем режим "без обработки".

Режим "без обработки"

Этот режим устанавливается с помощью кнопки gbr_select_mode0_png. Каждый файл и каждый элемент из этого файла будет выводится на экран в том порядке, в котором они были загружены. Но при этом, активный слой будет выведен последним.

Если Gerber-файлы имеют негативные элементы, то на уже нарисованных слоях появятся артефакты.

gerbview_mode_raw_stack_png

"Пакетный" режим

Устанавливается с помощью gbr_select_mode1_png, каждый файл выводится на экран в том порядке, в котором они были загружены. При этом, активный слой, тоже, будет выведен последним.

Если Gerber-файлы имеют негативные элементы, то на уже нарисованных слоях артефакты не появляются, потому что каждый файл рисуется в локальном буфере перед отображением на экране.

gerbview_mode_raw_stack_png

"Прозрачный" режим

Используйте кнопку gbr_select_mode2_png для отображения в этом режиме, в котором нет никаких артефактов и слои смешиваются вместе с верхним активным слоем.

gerbview_mode_transparency_png

Скрытые элементы нижних слоёв

В режиме "без обработки" и "пакетном" режиме активный слой всегда располагается вверху, над остальными слоями, и скрывает элементы под собой.

Здесь слой 1 (зелёный) — активный (заметьте, стрелка указывает на него) и он отображается поверх слоя 2 (синего):

gerbview_layer_select_1_png

Сделав слой 2 (синий) активным, он переместиться наверх:

gerbview_layer_select_2_png

Перемещение элементов

При работе в устаревшем режиме отображения, элементы можно выделять с помощью мыши, для этого нажимают левую кнопку и, не отпуская её, перемещают курсор, формируя прямоугольник выделения. Отпустив кнопку, элементы будут выделены и готовы к перемещению. Повторное, кратковременное, нажатие левой кнопки мыши расположит элементы в новом месте.

Этот приём работы является устаревшим и не доступен в современных режимах отображения.

Печать

Для печати слоёв используйте кнопку print_button_png или меню Файл → Печать.

Убедитесь, что элементы находятся внутри области печати. Выберите с помощью sheetset_png подходящий формат страницы.

Не забывайте, что фотоплоттеры могут использовать зону печати намного большую, чем размер страниц, используемых принтерами. Может потребоваться переместить весь набор слоёв.